Настройка тупиковой области в EIGRP (stub area)

В данной работе мы научимся выделять и конфигурировать тупиковые области в EIGRP.
Топология сети:

Интерфейсы настроены в соответствии с топологией сети. Настроим EIGRP между узлами, объявив все доступные сети, и, отключив автоматическое суммирование маршрутов (его мы настроим вручную от R3 к R2).

R1:

R1#sh run | sec router eigrp 100
router eigrp 100
 network 1.0.0.0
 network 10.0.0.0
 eigrp router-id 1.1.1.1
 no auto-summary

R2:

R2#sh run | sec router eigrp 100
router eigrp 100
 network 1.0.0.0
 network 2.0.0.0
 network 20.0.0.0
 eigrp router-id 2.2.2.2
 no auto-summary

R3:


R3#sh run | sec router eigrp 100
router eigrp 100
 network 2.0.0.0
 network 30.0.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 network 192.168.5.0
 network 192.168.6.0
 network 192.168.7.0
 eigrp router-id 3.3.3.3
 no auto-summary
R3#
R3#sh run int s1/0
Building configuration...

Current configuration : 137 bytes
!
interface Serial1/0
 ip address 2.2.2.2 255.0.0.0
 ip summary-address eigrp 100 192.168.0.0 255.255.248.0
end

После настройки устройств EIGRP-соседства установлены, а в таблице маршрутизации появились объявленные сети, причем сети 192.168.0.0/24-192.168.7.0/24 показаны как одна суперсеть 192.168.0.0/21.
R1:

R1#sh ip eigrp neighbors      
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   1.1.1.2                 Se1/0                    13 00:23:46  665  3990  0  10
R1#
R1#
R1#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     2.0.0.0/8 [90/2681856] via 1.1.1.2, 00:23:49, Serial1/0
D     20.0.0.0/8 [90/2195456] via 1.1.1.2, 00:23:49, Serial1/0
D     30.0.0.0/8 [90/2195456] via 1.1.1.2, 00:23:49, Serial1/0
D     192.168.0.0/21 [90/2809856] via 1.1.1.2, 00:23:49, Serial1/0

R2:

R2#sh ip eigrp neighbors 
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   1.1.1.1                 Se1/0                    11 00:24:13   14   100  0  6
0   2.2.2.2                 Se1/1                    12 00:24:14   20   120  0  6
R2#
R2#
R2#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     10.0.0.0/8 [90/2195456] via 1.1.1.1, 00:24:24, Serial1/0
D     30.0.0.0/8 [90/2297856] via 2.2.2.2, 00:24:27, Serial1/1
D     192.168.0.0/21 [90/2297856] via 2.2.2.2, 00:24:27, Serial1/1

R3:

R3#sh ip eigrp neighbors 
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   2.2.2.1                 Se1/0                    12 00:25:15   12   100  0  11
R3#
R3#
R3#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     1.0.0.0/8 [90/2681856] via 2.2.2.1, 00:25:23, Serial1/0
D     10.0.0.0/8 [90/2707456] via 2.2.2.1, 00:25:23, Serial1/0
D     20.0.0.0/8 [90/2195456] via 2.2.2.1, 00:25:26, Serial1/0
D     192.168.0.0/21 is a summary, 00:25:29, Null0

Теперь давайте настроим на R3 тупиковую область, сделав так, чтобы роутер получал EIGRP-обновления, но сам свои сети не анонсировал:

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#
R3(config)#router eigrp 100
R3(config-router)#eigrp stub receive-only
R3(config-router)#end

После ввода данной команды, видно, что EIGRP-соседство было переустановлено:

*Nov 19 11:30:50.609: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 2.2.2.1 (Serial1/0) is down: peer info changed
*Nov 19 11:30:53.240: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 2.2.2.1 (Serial1/0) is up: new adjacency

Теперь, взглянув на таблицы маршрутизации, видно, что R3 действительно получает EIGRP-обновления, но сам своими сетями не делится:
R1:

R1#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     2.0.0.0/8 [90/2681856] via 1.1.1.2, 00:47:27, Serial1/0
D     20.0.0.0/8 [90/2195456] via 1.1.1.2, 00:47:27, Serial1/0

R2:

R2#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     10.0.0.0/8 [90/2195456] via 1.1.1.1, 00:47:44, Serial1/0

R3:

R3#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     1.0.0.0/8 [90/2681856] via 2.2.2.1, 00:05:15, Serial1/0
D     10.0.0.0/8 [90/2707456] via 2.2.2.1, 00:05:15, Serial1/0
D     20.0.0.0/8 [90/2195456] via 2.2.2.1, 00:05:15, Serial1/0
D     192.168.0.0/21 is a summary, 00:48:04, Null0

Теперь настроим EIGRP stub на R3, разрешая R3 отправлять только подключенные сети в сторону R2:

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router eigrp 100
R3(config-router)#no eigrp stub receive-only
R3(config-router)#eigrp stub connected
R3(config-router)#end

После ввода вышеуказанных команд у нас заново установится EIGRP-соседство между R2 и R3. Смотрим выводы таблицы маршрутизации:

R1:

R1#sh ip route eigrp | begin Gateway 
Gateway of last resort is not set

D     2.0.0.0/8 [90/2681856] via 1.1.1.2, 02:29:51, Serial1/0
D     20.0.0.0/8 [90/2195456] via 1.1.1.2, 02:29:51, Serial1/0
D     30.0.0.0/8 [90/2707456] via 1.1.1.2, 00:00:54, Serial1/0
D     192.168.0.0/24 [90/2809856] via 1.1.1.2, 00:00:54, Serial1/0
D     192.168.1.0/24 [90/2809856] via 1.1.1.2, 00:00:54, Serial1/0
D     192.168.2.0/24 [90/2809856] via 1.1.1.2, 00:00:54, Serial1/0
D     192.168.3.0/24 [90/2809856] via 1.1.1.2, 00:00:54, Serial1/0
D     192.168.4.0/24 [90/2809856] via 1.1.1.2, 00:00:54, Serial1/0
D     192.168.5.0/24 [90/2809856] via 1.1.1.2, 00:00:54, Serial1/0
D     192.168.6.0/24 [90/2809856] via 1.1.1.2, 00:00:54, Serial1/0
D     192.168.7.0/24 [90/2809856] via 1.1.1.2, 00:00:54, Serial1/0

R2:

R2#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     10.0.0.0/8 [90/2195456] via 1.1.1.1, 02:29:53, Serial1/0
D     30.0.0.0/8 [90/2195456] via 2.2.2.2, 00:00:56, Serial1/1
D     192.168.0.0/24 [90/2297856] via 2.2.2.2, 00:00:56, Serial1/1
D     192.168.1.0/24 [90/2297856] via 2.2.2.2, 00:00:56, Serial1/1
D     192.168.2.0/24 [90/2297856] via 2.2.2.2, 00:00:56, Serial1/1
D     192.168.3.0/24 [90/2297856] via 2.2.2.2, 00:00:56, Serial1/1
D     192.168.4.0/24 [90/2297856] via 2.2.2.2, 00:00:56, Serial1/1
D     192.168.5.0/24 [90/2297856] via 2.2.2.2, 00:00:56, Serial1/1
D     192.168.6.0/24 [90/2297856] via 2.2.2.2, 00:00:56, Serial1/1
D     192.168.7.0/24 [90/2297856] via 2.2.2.2, 00:00:56, Serial1/1

R3:

R3#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     1.0.0.0/8 [90/2681856] via 2.2.2.1, 00:02:26, Serial1/0
D     10.0.0.0/8 [90/2707456] via 2.2.2.1, 00:02:26, Serial1/0
D     20.0.0.0/8 [90/2195456] via 2.2.2.1, 00:02:26, Serial1/0
D     192.168.0.0/21 is a summary, 00:00:18, Null0

Как мы видим, на R3 есть суммарный маршрут 192.168.0.0/21, но R2 он не передался, поскольку у нас в настройках маршрутизатора было указано передавать только подключенные сети.
Исправим это, на этот раз разрешая передавать только суммарные сети:

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router eigrp 100
R3(config-router)#no eigrp stub connected
R3(config-router)#eigrp stub summary
R3(config-router)#end

Проверим результаты:

R1:

R1#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     2.0.0.0/8 [90/2681856] via 1.1.1.2, 02:32:29, Serial1/0
D     20.0.0.0/8 [90/2195456] via 1.1.1.2, 02:32:29, Serial1/0
D     192.168.0.0/21 [90/2809856] via 1.1.1.2, 00:00:06, Serial1/0

R2:

R2#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     10.0.0.0/8 [90/2195456] via 1.1.1.1, 02:32:30, Serial1/0
D     192.168.0.0/21 [90/2297856] via 2.2.2.2, 00:00:08, Serial1/1

R3:

R3#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     1.0.0.0/8 [90/2681856] via 2.2.2.1, 00:00:05, Serial1/0
D     10.0.0.0/8 [90/2707456] via 2.2.2.1, 00:00:05, Serial1/0
D     20.0.0.0/8 [90/2195456] via 2.2.2.1, 00:00:05, Serial1/0
D     192.168.0.0/21 is a summary, 00:01:23, Null0

Готово, суммарный маршрут от R3 успешно анонсируется, но вот теперь недоступна сеть 30.0.0.0/8. Исправим и этот недостаток:

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router eigrp 100
R3(config-router)#no eigrp stub summary
R3(config-router)#eigrp stub
R3(config-router)#end

Смотрим таблицы маршрутизации:

R1:

R1#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     2.0.0.0/8 [90/2681856] via 1.1.1.2, 02:37:28, Serial1/0
D     20.0.0.0/8 [90/2195456] via 1.1.1.2, 02:37:28, Serial1/0
D     30.0.0.0/8 [90/2707456] via 1.1.1.2, 00:01:57, Serial1/0
D     192.168.0.0/21 [90/2809856] via 1.1.1.2, 00:01:57, Serial1/0

R2:

R2#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     10.0.0.0/8 [90/2195456] via 1.1.1.1, 02:37:29, Serial1/0
D     30.0.0.0/8 [90/2195456] via 2.2.2.2, 00:01:58, Serial1/1
D     192.168.0.0/21 [90/2297856] via 2.2.2.2, 00:01:58, Serial1/1

R3:

R3#sh ip route eigrp | begin Gateway
Gateway of last resort is not set

D     1.0.0.0/8 [90/2681856] via 2.2.2.1, 00:01:59, Serial1/0
D     10.0.0.0/8 [90/2707456] via 2.2.2.1, 00:01:59, Serial1/0
D     20.0.0.0/8 [90/2195456] via 2.2.2.1, 00:01:59, Serial1/0
D     192.168.0.0/21 is a summary, 00:06:25, Null0

Готово, все сети успешно анонсируются, этого можно было добиться и другой командой:

Router(config-router)#eigrp stub summary connected

На этом настройку тупиковой области EIGRP можно считать завершенной.

2 thoughts on “Настройка EIGRP. Тупиковая область”

  1. Добрый день!

    Если не ошибаюсь, команда «eigrp stub» по умолчанию использует параметры summary + connected. Так что последняя команда (eigrp stub summary connected) аналогична по функционалу «eigrp stub».

    Полезная статья.

    1. 3fc, доброго времени суток!
      Спасибо, что заглянули, давно ничего нового не писал, а тут вроде даже стимул начинает появляться:)
      Насчет эквивалентности eigrp stub и eigrp stub summary connected Вы правы, в статье я это также указал:
      «этого можно было добиться и другой командой:
      Router(config-router)#eigrp stub summary connected
      »

      Спасибо за обратную связь, приятно, что кто-то заглядывает хоть иногда.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.