Настройка суммирования маршрутов в EIGRP

Топология сети:

В EIGRP есть такая удобная функция, как суммирование маршрутов. Возьмем схему из предыдущей работы и добавим на R3 Loopback-интерфейсы с соответствующими адресами:

R3#sh run | section Loopback
interface Loopback1
 ip address 192.168.0.1 255.255.255.0
interface Loopback2
 ip address 192.168.1.1 255.255.255.0
interface Loopback3
 ip address 192.168.2.1 255.255.255.0
interface Loopback4
 ip address 192.168.3.1 255.255.255.0
interface Loopback5
 ip address 192.168.4.1 255.255.255.0
interface Loopback6
 ip address 192.168.5.1 255.255.255.0
interface Loopback7
 ip address 192.168.6.1 255.255.255.0
interface Loopback8
 ip address 192.168.7.1 255.255.255.0

Теперь объявим эти сети в существующем процессе EIGRP (AS 100):

R3#conf t
R3(config)#router eigrp 100
R3(config-router)#netw 192.168.0.1 0.0.0.255
R3(config-router)#netw 192.168.1.1 0.0.0.255
R3(config-router)#netw 192.168.2.1 0.0.0.255
R3(config-router)#netw 192.168.3.1 0.0.0.255
R3(config-router)#netw 192.168.4.1 0.0.0.255
R3(config-router)#netw 192.168.5.1 0.0.0.255
R3(config-router)#netw 192.168.6.1 0.0.0.255
R3(config-router)#netw 192.168.7.1 0.0.0.255
R3(config-router)#end

Просмотрев таблицу маршрутизации на R1 и R2 видно, что от R3 мы получили всю пачку этих сетей, что делает таблицу маршрутизации несколько громоздкой. Хорошо, что еще сетей всего 8, а если 800?

R1:

R1#sh ip route | begin Gateway
Gateway of last resort is 1.1.1.2 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/2681856] via 1.1.1.2, 00:19:12, Serial1/0
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial1/0
L        1.1.1.1/32 is directly connected, Serial1/0
D     2.0.0.0/8 [90/2681856] via 1.1.1.2, 00:19:12, Serial1/0
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, Ethernet0/0
L        10.1.1.1/32 is directly connected, Ethernet0/0
D     20.0.0.0/8 [90/2195456] via 1.1.1.2, 00:19:15, Serial1/0
D     192.168.0.0/24 [90/2809856] via 1.1.1.2, 00:03:24, Serial1/0
D     192.168.1.0/24 [90/2809856] via 1.1.1.2, 00:03:20, Serial1/0
D     192.168.2.0/24 [90/2809856] via 1.1.1.2, 00:03:17, Serial1/0
D     192.168.3.0/24 [90/2809856] via 1.1.1.2, 00:03:14, Serial1/0
D     192.168.4.0/24 [90/2809856] via 1.1.1.2, 00:03:12, Serial1/0
D     192.168.5.0/24 [90/2809856] via 1.1.1.2, 00:03:09, Serial1/0
D     192.168.6.0/24 [90/2809856] via 1.1.1.2, 00:03:07, Serial1/0
D     192.168.7.0/24 [90/2809856] via 1.1.1.2, 00:03:05, Serial1/0

R2:

R2#sh ip route | begin Gateway
Gateway of last resort is 2.2.2.2 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 2.2.2.2
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial1/0
L        1.1.1.2/32 is directly connected, Serial1/0
      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.0.0.0/8 is directly connected, Serial1/1
L        2.2.2.1/32 is directly connected, Serial1/1
D     10.0.0.0/8 [90/2195456] via 1.1.1.1, 00:19:07, Serial1/0
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.0.0.0/8 is directly connected, Ethernet0/0
L        20.1.1.1/32 is directly connected, Ethernet0/0
D     192.168.0.0/24 [90/2297856] via 2.2.2.2, 00:03:16, Serial1/1
D     192.168.1.0/24 [90/2297856] via 2.2.2.2, 00:03:12, Serial1/1
D     192.168.2.0/24 [90/2297856] via 2.2.2.2, 00:03:09, Serial1/1
D     192.168.3.0/24 [90/2297856] via 2.2.2.2, 00:03:06, Serial1/1
D     192.168.4.0/24 [90/2297856] via 2.2.2.2, 00:03:04, Serial1/1
D     192.168.5.0/24 [90/2297856] via 2.2.2.2, 00:03:01, Serial1/1
D     192.168.6.0/24 [90/2297856] via 2.2.2.2, 00:02:59, Serial1/1
D     192.168.7.0/24 [90/2297856] via 2.2.2.2, 00:02:57, Serial1/1

Итого, общая конфигурация EIGRP на всех трех узлах будет выглядеть так:

R1:

R1#sh run | sec router eigrp 100
router eigrp 100
 network 1.0.0.0
 network 10.0.0.0
 eigrp router-id 1.1.1.1

R2:

R2#sh run | sec router eigrp 100
router eigrp 100
 network 1.0.0.0
 network 2.0.0.0
 network 20.0.0.0
 redistribute static
 eigrp router-id 2.2.2.2

R3:

R3#sh run | sec router eigrp 100
router eigrp 100
 network 2.0.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 network 192.168.5.0
 network 192.168.6.0
 network 192.168.7.0
 eigrp router-id 3.3.3.3

Теперь давайте попробуем несколько сократить количество сетей. Делается это следующим образом:
1) Для списка сетей вычисляется суперсеть, содержащая в себе все подсети, которые мы хотим объединить
2) На интерфейсе в сторону EIGRP-соседа прописывается команда ip summary-address eigrp autonomous-system network netmask

Итак, наша цель: проанонсировать суперсеть с маршрутизатора R3 в сторону R2:
— для сетей из диапазона 192.168.0.0/24 — 192.168.7.0/24 необходимо подобрать общую псеть, и она будет выглядеть так: 192.168.0.0 255.255.248.0 (192.168.0.0/21)
— после расчета общей сети на R3 выбираем интерфейс в сторону EIGRP-соседа. В нашем случае это будет интерфейс Serial1/0. Пропишем вышеуказанную команду в режиме конфигурации интерфейса:

R3(config)#int s1/0
R3(config-if)#ip summary-address eigrp 100 192.168.0.0 255.255.248.0
R3(config-if)#end
R3#
*Nov 13 14:48:55.365: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 2.2.2.1 (Serial1/0) is resync: summary configured

После этого смотрим таблицы маршрутизации на устройствах. Для удобства сделаю фильтр по нашей сети:
R3:

R3#sh ip route | i 192.168
D     192.168.0.0/21 is a summary, 00:02:09, Null0
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Loopback1
L        192.168.0.1/32 is directly connected, Loopback1
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Loopback2
L        192.168.1.1/32 is directly connected, Loopback2
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, Loopback3
L        192.168.2.1/32 is directly connected, Loopback3
      192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.3.0/24 is directly connected, Loopback4
L        192.168.3.1/32 is directly connected, Loopback4
      192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.4.0/24 is directly connected, Loopback5
L        192.168.4.1/32 is directly connected, Loopback5
      192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.5.0/24 is directly connected, Loopback6
L        192.168.5.1/32 is directly connected, Loopback6
      192.168.6.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.6.0/24 is directly connected, Loopback7
L        192.168.6.1/32 is directly connected, Loopback7
      192.168.7.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.7.0/24 is directly connected, Loopback8
L        192.168.7.1/32 is directly connected, Loopback8

С суммированием маршрута на R3 также появилась запись в таблице маршрутизации, которая ссылается на интерфейс Null0.

D     192.168.0.0/21 is a summary, 00:02:09, Null0

Это означает, что суммарный маршрут успешно создан и распространен по автономной системе EIGRP.
Посмотрим, как выглядит таблица маршрутизации на R2:

R2#sh ip route | begin Gateway
Gateway of last resort is 2.2.2.2 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 2.2.2.2
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial1/0
L        1.1.1.2/32 is directly connected, Serial1/0
      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.0.0.0/8 is directly connected, Serial1/1
L        2.2.2.1/32 is directly connected, Serial1/1
D     10.0.0.0/8 [90/2195456] via 1.1.1.1, 01:09:19, Serial1/0
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.0.0.0/8 is directly connected, Ethernet0/0
L        20.1.1.1/32 is directly connected, Ethernet0/0
D     192.168.0.0/21 [90/2297856] via 2.2.2.2, 00:42:00, Serial1/1
R2#
R2#ping 192.168.5.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/10 ms
R2#ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 9/9/10 ms

Как видим, теперь в таблице маршрутизации есть только одна суперсеть, вместо восьми маленьких, как это было ранее. И даже Loopback-интерфейсы пингуются.
Аналогичное можем наблюдать на R1:

R1#sh ip route | begin Gateway
Gateway of last resort is 1.1.1.2 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/2681856] via 1.1.1.2, 01:12:21, Serial1/0
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial1/0
L        1.1.1.1/32 is directly connected, Serial1/0
D     2.0.0.0/8 [90/2681856] via 1.1.1.2, 01:12:21, Serial1/0
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, Ethernet0/0
L        10.1.1.1/32 is directly connected, Ethernet0/0
D     20.0.0.0/8 [90/2195456] via 1.1.1.2, 01:12:24, Serial1/0
D     192.168.0.0/21 [90/2809856] via 1.1.1.2, 00:45:05, Serial1/0
R1#
R1#ping 192.168.0.1           
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 18/19/20 ms
R1#ping 192.168.7.1           
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 19/19/20 ms

На этом суммирование маршрутов можно считать завершенным.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.