Ниже приведен подробный разбор решения лабораторной работы по настройке EIGRP уровня CCNA. Задание к лабораторной работе можно увидеть по этой ссылке.

Лабораторную работу я выполнял в среде EVE-NG, физическая топология выглядит следующим образом:

Итак, пойдем по-порядку:

    1. Настроить порты коммутатора следующим образом:
    • E0/0: trunk, разрешенные vlan 12,14,16
    • E0/1: trunk, разрешенные vlan 12,23
    • E0/2: trunk, разрешенные vlan 12,23,34
    • E0/3: trunk, разрешенный vlan 14,34
    • E1/0: access, vlan 16

    На всех интерфейсах отключить cdp, все незадействованные интерфейсы отправить в состояние admin-down

Прежде всего, создадим нужные нам вланы:

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 12
Switch(config-vlan)#vlan 14
Switch(config-vlan)#vlan 16
Switch(config-vlan)#vlan 23
Switch(config-vlan)#vlan 34
Switch(config-vlan)#end
Switch#

Назначим вышеуказанным интерфейсам режим работы и номера vlan’ов в соответствии с заданием:

Switch(config)#int e0/0
Switch(config-if)#no shutdown
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 12,14,16
Switch(config-if)#no cdp enable
Switch(config-if)#int e0/1
Switch(config-if)#no shutdown
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 12,23
Switch(config-if)#no cdp enable
Switch(config-if)#int e0/2
Switch(config-if)#no shutdown
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 12,23,34
Switch(config-if)#no cdp enable
Switch(config-if)#int e0/3
Switch(config-if)#no shutdown
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan 14,34
Switch(config-if)#no cdp enable
Switch(config-if)#end

Теперь осталось отключить незадействованные интерфейсы:

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int range e1/1-3
Switch(config-if-range)#shutdown
Switch(config-if-range)#end

  1. Настроить интерфейсы всех маршрутизаторов в соответствии с приведенной топологией

На этом задании останавливаться не буду, ибо ничего сложного нет. Идем дальше.

 

  1. Настроить протокол динамической маршрутизации EIGRP между узлами R4 и R5:
    • указать номер AS 101
    • на R5 объявить все доступные сети
    • на R4 объявить только сети, смотрящие в сторону R5
    • сделать все интерфейсы на обоих маршрутизаторах пассивными по умолчанию, отдельно активировав нужные интерфейсы
    • отключить автоматическое суммирование

R4:

R4#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R4(config)#router eigrp 101
R4(config-router)#passive-interface default 
R4(config-router)#netw 10.0.0.0 0.0.0.3
R4(config-router)#netw 10.0.0.4 0.0.0.3
R4(config-router)#no auto-summary 
R4(config-router)#no passive-interface s1/0
R4(config-router)#no passive-interface s1/1
R4(config-router)#end

R5:

R5#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R5(config)#router eigrp 101
R5(config-router)#passive-interface default 
R5(config-router)#no auto-summary 
R5(config-router)#netw 10.0.0.0 0.0.0.3
R5(config-router)#netw 10.0.0.4 0.0.0.3
R5(config-router)#netw 192.168.254.0
R5(config-router)#netw 192.168.255.0 0.0.0.127
R5(config-router)#netw 192.168.255.128 0.0.0.127
R5(config-router)#no passive-interface s1/0
R5(config-router)#no passive-interface s1/1
R5(config-router)#end
R5#

После ввода конфигов видно, что EIGRP-соседство установилось и на R1 видны все сети R6:

R1#sh ip eigrp neighbors 
IP-EIGRP neighbors for process 100
IP-EIGRP neighbors for process 101
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.0.16.2               Fa0/0.16          12 00:03:48   38   228  0  13
R1#
R1#sh ip route eigrp     
D    192.168.0.0/24 [90/409600] via 10.0.16.2, 00:03:49, FastEthernet0/0.16
D    192.168.1.0/24 [90/409600] via 10.0.16.2, 00:03:49, FastEthernet0/0.16
     192.168.2.0/30 is subnetted, 1 subnets
D       192.168.2.0 [90/409600] via 10.0.16.2, 00:03:47, FastEthernet0/0.16
D    192.168.3.0/24 [90/409600] via 10.0.16.2, 00:03:49, FastEthernet0/0.16

Идем дальше:

  1. Настроить протокол динамической маршрутизации EIGRP на оставшихся узлах (не настраивая узел ISP):
  • — указать номер AS 100
  • — объявить все доступные сети
  • — на всех узлах сделать все интерфейсы пассивными по умолчанию, отдельно активировав нужные интерфейсы
  • — отключить автоматическое суммирование
  • — между R2 и R3 настроить hello и dead таймеры, равными 10 и 30 соответственно
  • — между R1 и R4 настроить аутентификацию, использовав в качестве пароля ключевое слово LabEIGRP
  • — на R3 не анонсируем сеть, смотрящую в сторону ISP

Начнем с объявления всех сетей и активации нужных интерфейсов в AS 100:
R1:

R1(config)#router eigrp 100
R1(config-router)#passive-interface default
R1(config-router)#network 10.0.16.0 0.0.0.3
R1(config-router)#network 10.0.12.0 0.0.0.3
R1(config-router)#network 10.0.14.0 0.0.0.3
R1(config-router)#network 192.168.0.0 0.0.0.127
R1(config-router)#network 192.168.129.0 0.0.0.127
R1(config-router)#no auto-summary 
R1(config-router)#no passive-interface fa0/0.12
R1(config-router)#no passive-interface fa0/0.14
R1(config-router)#no passive-interface fa0/0.16
R1(config-router)#end

R2:

R2(config)#router eigrp 100
R2(config-router)#network 10.0.12.0 0.0.0.3 
R2(config-router)#network 192.168.10.0 0.0.0.127
R2(config-router)#network 192.168.10.128 0.0.0.63 
R2(config-router)#network 192.168.10.192 0.0.0.63
R2(config-router)#no auto-summary
R2(config-router)#no passive-interface fa0/0.12
R2(config-router)#no passive-interface fa0/0.23
R2(config-router)#end

R3:

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router eigrp 100
R3(config-router)#passive-interface default
R3(config-router)#network 10.0.23.0 0.0.0.3
R3(config-router)#network 10.0.34.0 0.0.0.3
R3(config-router)#network 192.168.11.0
R3(config-router)#no auto-summary
R3(config-router)#no passive-interface fa0/0.23
R3(config-router)#no passive-interface fa0/0.  
R3(config-router)#no passive-interface fa0/0.34
R3(config-router)#end

R4:

R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#router eigrp 100
R4(config-router)#passive-interface default
R4(config-router)#network 10.0.14.0 0.0.0.3
R4(config-router)#network 10.0.34.0 0.0.0.3
R4(config-router)#network 192.168.240.0 0.0.0.127
R4(config-router)#network 192.168.240.128 0.0.0.31
R4(config-router)#network 192.168.240.192 0.0.0.31
R4(config-router)#network 192.168.240.224 0.0.0.31                                    
R4(config-router)#no passive-interface e0/0.14 
R4(config-router)#no passive-interface e0/0.34
R4(config-router)#end

R6:

R6#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R6(config)#router eigrp 100
R6(config-router)#passive-interface default
R6(config-router)# no passive-interface FastEthernet0/0
R6(config-router)# network 10.0.16.0 0.0.0.3
R6(config-router)# network 192.168.0.0
R6(config-router)# network 192.168.1.0
R6(config-router)# network 192.168.2.0
R6(config-router)# network 192.168.3.0
R6(config-router)# no auto-summary
R6(config-router)#end 

Настроим таймеры между R2 и R3:
R2:

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int fa0/0.23
R2(config-subif)#ip hello-interval eigrp 100 10
R2(config-subif)#ip hold-time eigrp 100 30
R2(config-subif)#end

R3:

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#int fa0/0.23
R3(config-subif)#ip hello-interval eigrp 100 10
R3(config-subif)#ip hold-time eigrp 100 30
R3(config-subif)#end

Глянув детальные настройки EIGRP-интерфейса на R3, видим, что значения таймеров изменились:

R3#show ip eigrp interfaces detail fa0/0.23
IP-EIGRP interfaces for process 100

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0.23           1        0/0        31       0/2          136           0
  Hello interval is 10 sec
  Next xmit serial 
  Un/reliable mcasts: 0/4  Un/reliable ucasts: 6/4
  Mcast exceptions: 1  CR packets: 1  ACKs suppressed: 0
  Retransmissions sent: 2  Out-of-sequence rcvd: 0
  Authentication mode is not set
  Use multicast

Осталось настроить аутентификацию между R1 и R4:
R1:

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#key chain Lab1
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string LabEIGRP
R1(config-keychain-key)#exit
R1(config-keychain)#exit
R1(config)#int fa0/0.14
R1(config-subif)#ip authentication key-chain eigrp 100 Lab1 
R1(config-subif)#end

R4:

R4#conf t
*Dec  3 18:11:09.885: %SYS-5-CONFIG_I: Configured from console by console
R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#key chain Lab1
R4(config-keychain)#key 1
R4(config-keychain-key)#key-string LabEIGRP
R4(config-keychain-key)#exit
R4(config-keychain)#exit
R4(config)#int e0/0.14
R4(config-subif)#ip authentication key-chain eigrp 100 Lab1 
R4(config-subif)#end
  1. Настройка роутера ISP:
  • — на роутере настроены статические маршруты до сетей 10.0.0.0/18, 192.168.0.0/16 через интерфейс Fa0/0
  • — IP-адреса на интерфейсах настроены в соответствии с логической топологией

ISP:

ISP#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ISP(config)#int fa0/0
ISP(config-if)#no sh
ISP(config-if)#ip addr 198.254.0.1 255.255.255.252
ISP(config-if)#int fa0/1
ISP(config-if)#no sh
ISP(config-if)#ip addr 198.254.1.1 255.255.255.240
ISP(config-if)#exit
ISP(config)#ip route 10.0.0.0 255.255.192.0 fa0/0
ISP(config)#ip route 192.168.0.0 255.255.0.0 fa0/0
ISP(config)#end

alkdjas

  1. Настройка и редистрибьюция дефолтного статического маршрута
  • — на R3 настроить маршрут по умолчанию, указав в качестве выходного интерфейса порт, смотрящий в сторону ISP.
  • — настроить редистрибьюцию статических маршрутов в EIGRP AS 100

Настроим статический маршрут через интерфейс Fa0/1 и объявим его всем устройствам в AS100:

R3:


R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#ip route 0.0.0.0 0.0.0.0 fa0/1
R3(config)#router eigrp 100
R3(config-router)#redistribute static
R3(config-router)#end

Проверим наличие появившегося статического маршрута на любом из роутеров в AS100:

R5#sh ip route eigrp | sec D*EX
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
D*EX  0.0.0.0/0 [170/2221056] via 10.0.0.5, 00:02:45, Serial1/1
                [170/2221056] via 10.0.0.1, 00:02:45, Serial1/0

Как видим, дефолтный маршрут передался по всей автономной системе. Идем далее.

  1. Настройка тупиковой автономной системы:
  • — маршрутизатор R6 настроить в качестве тупиковой автономной системы, позволяя ему получить от R1 все доступные сети, но свои сети не анонсировать
  • — на R1 настроить статический маршрут до сетей на R1, указав в качестве адреса следующего перехода IP-адрес R6, настроить редистрибьюцию статического маршрута

Поскольку на R6 нужно только получить маршруты, используем параметр stub receive-only:

R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
*Mar  1 05:25:30.870: %SYS-5-CONFIG_I: Configured from console by console   
R6(config)#router eigrp 100
R6(config-router)#eigrp stub receive-only
R6(config-router)#end

Поскольку на R6 находятся четыре /24 сети, можем их объединить в одну общую сеть:

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#ip route 192.168.0.0 255.255.252.0 fa0/0.16
R1(config)#router eigrp 100
R1(config-router)#redistribute static 
R1(config-router)#end
  1. Настроить редистрибьюцию маршрутов из EIGRP 100 в EIGRP 101 и наоборот

R4:

R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#router eigrp 100
R4(config-router)#redistribute eigrp 101
R4(config-router)#exit
R4(config)#router eigrp 101
R4(config-router)#redistribute eigrp 100
R4(config-router)#end

Если все прошло успешно, на R5 должны появиться все маршруты из AS100, но с пометкой D*EX:

R5#sh ip route eigrp | begin Gateway
Gateway of last resort is 10.0.0.5 to network 0.0.0.0

D*EX  0.0.0.0/0 [170/2221056] via 10.0.0.5, 00:02:54, Serial1/1
                [170/2221056] via 10.0.0.1, 00:02:54, Serial1/0
      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
D EX     10.0.12.0/30 [170/2221056] via 10.0.0.5, 00:02:54, Serial1/1
                      [170/2221056] via 10.0.0.1, 00:02:54, Serial1/0
D EX     10.0.14.0/30 [170/2195456] via 10.0.0.5, 00:02:54, Serial1/1
                      [170/2195456] via 10.0.0.1, 00:02:54, Serial1/0
D EX     10.0.16.0/30 [170/2221056] via 10.0.0.5, 00:02:54, Serial1/1
                      [170/2221056] via 10.0.0.1, 00:02:54, Serial1/0
D EX     10.0.23.0/30 [170/2221056] via 10.0.0.5, 00:02:54, Serial1/1
                      [170/2221056] via 10.0.0.1, 00:02:54, Serial1/0
D EX     10.0.34.0/30 [170/2195456] via 10.0.0.5, 00:02:54, Serial1/1
                      [170/2195456] via 10.0.0.1, 00:02:54, Serial1/0
D EX  192.168.0.0/22 [170/2221056] via 10.0.0.5, 00:02:54, Serial1/1
                     [170/2221056] via 10.0.0.1, 00:02:54, Serial1/0
      192.168.9.0/25 is subnetted, 1 subnets
D EX     192.168.9.0 [170/2323456] via 10.0.0.5, 00:02:54, Serial1/1
                     [170/2323456] via 10.0.0.1, 00:02:54, Serial1/0
      192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
D EX     192.168.10.0/25 [170/2349056] via 10.0.0.5, 00:02:54, Serial1/1
                         [170/2349056] via 10.0.0.1, 00:02:54, Serial1/0
D EX     192.168.10.128/26 [170/2349056] via 10.0.0.5, 00:02:54, Serial1/1
                           [170/2349056] via 10.0.0.1, 00:02:54, Serial1/0
D EX     192.168.10.192/26 [170/2246656] via 10.0.0.5, 00:02:54, Serial1/1
                           [170/2246656] via 10.0.0.1, 00:02:54, Serial1/0
D EX  192.168.11.0/24 [170/2323456] via 10.0.0.5, 00:02:54, Serial1/1
                      [170/2323456] via 10.0.0.1, 00:02:54, Serial1/0
      192.168.240.0/24 is variably subnetted, 3 subnets, 2 masks
D EX     192.168.240.0/25 [170/2297856] via 10.0.0.5, 00:02:54, Serial1/1
                          [170/2297856] via 10.0.0.1, 00:02:54, Serial1/0
D EX     192.168.240.192/27 [170/2297856] via 10.0.0.5, 00:02:54, Serial1/1
                            [170/2297856] via 10.0.0.1, 00:02:54, Serial1/0
D EX     192.168.240.224/27 [170/2195456] via 10.0.0.5, 00:02:54, Serial1/1
                            [170/2195456] via 10.0.0.1, 00:02:54, Serial1/0
  1. На R2, R4 и R5 вручную настроить суммирование маршрутов, объявив суммарные сети на соответствующих интерфейсах

Для ручного суммирования для начала вычислим суперсети для R2, R4 и R5:
R2: 192.168.10.0/24, анонсируем через интерфейсы Fa0/0.12 и Fa0/0.23
R4: 192.168.240.0/24, анонсируем через интерфейсы E0/0.14, E0/0.34, S1/0 и S1/1
R5: 192.168.254.0/23, анонсируем через интерфейсы S1/0 и S1/1
R2:

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int fa0/0.12
R2(config-subif)#ip summary-address eigrp 100 192.168.10.0 255.255.255.0
R2(config-subif)#int fa0/0.23
R2(config-subif)#ip summary-address eigrp 100 192.168.10.0 255.255.255.0
R2(config-subif)#end

R4:

R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#int e0/0.14
R4(config-subif)#ip summary-address eigrp 100 192.168.240.0 255.255.255.0
R4(config-subif)#int e0
R4(config-subif)#int e0/0.34
R4(config-subif)#ip summary-address eigrp 100 192.168.240.0 255.255.255.0
R4(config-subif)#int s1/0
R4(config-if)#ip summary-address eigrp 101 192.168.240.0 255.255.255.0
R4(config-if)#int s1/1
R4(config-if)#ip summary-address eigrp 101 192.168.240.0 255.255.255.0
R4(config-if)#end

R5:

R5#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#int s1/0
R5(config-if)#ip summary-address eigrp 101 192.168.254.0 255.255.254.0
R5(config-if)#int s1/1
R5(config-if)#ip summary-address eigrp 101 192.168.254.0 255.255.254.0
R5(config-if)#end

Готово, осталась заключительная часть задания:

  1. Настройка балансировки трафика между узлами R4 и R5
  • — на интерфейсах S1/0 указать полосу пропускания равной 1.5 Mbps, на S1/1 — 600 Kbps
  • — сделать так, чтобы оба маршрута были доступны в таблице маршрутизации

Укажем полосу пропускания на обоих роутерах и проверим наличие маршрутов в таблице маршрутизации:
R4:

R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#int s1/0
R4(config-if)#bandwidth 1500
R4(config-if)#int s1/1 
R4(config-if)#bandwidth 600
R4(config-if)#end
R4#
R4#sh ip route eigrp 101 | begin Gateway
Gateway of last resort is 10.0.34.1 to network 0.0.0.0

D     192.168.254.0/23 [90/2346496] via 10.0.0.2, 00:01:28, Serial1/0

Из таблицы маршрутизации видно, что у нас добавлен всего один путь до сети 192.168.254.0/23. Глянем таблицу топологии:

R4#sh ip eigrp topology | sec 192.168.254.0/23
P 192.168.254.0/23, 1 successors, FD is 2297856
        via 10.0.0.2 (2346496/128256), Serial1/0
        via 10.0.0.6 (4906496/128256), Serial1/1

Из таблицы топологии видно, что метрики через разные интерфейсы отличаются. Для того, чтобы оба пути попали в таблицу маршрутизации, воспользуемся командой variance multiplier. Как я рассказывал ранее, при указанном multiplier роутер умножает FD на multiplier и добавляет в таблицу маршрутизации все пути, расстояние до которых попадает в диапазон от FD до FD*Multiplier. В нашем случае FD и стоимость пути через интерфейс S1/1 отличаются более чем в 2 раза, следовательно, Multiplier в нашем случае должен быть равен 3. Проверим это, указав variance 2:

R4:

R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#router eigrp 101
R4(config-router)#variance 2
R4(config-router)#end
R4#
R4#sh ip route eigrp 101 | begin Gateway
Gateway of last resort is 10.0.34.1 to network 0.0.0.0

D     192.168.254.0/23 [90/2346496] via 10.0.0.2, 00:00:14, Serial1/0

Так и вышло, новый маршрут не появился. Увеличим множитель на 1:

R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#router eigrp 101
R4(config-router)#variance 3
R4(config-router)#end
R4#
R4#sh ip route eigrp 101 | begin Gateway
Gateway of last resort is 10.0.34.1 to network 0.0.0.0

D     192.168.254.0/23 [90/4906496] via 10.0.0.6, 00:00:10, Serial1/1
                       [90/2346496] via 10.0.0.2, 00:00:10, Serial1/0

Сработало. Теперь в таблице маршрутизации у нас 2 пути до сети 192.168.254.0/23.
На этом выполнение лабораторной работы можно считать завершенным.

8 thoughts on “Лабораторная работа EIGRP. Подробный разбор задания.”

  1. Добрый день!

    А как вы добавили serial-интерфейс к маршрутизатору в EVE-NG? Я подключил образы vIOS, 1710, 3725, 7206 Dynamips — нигде не вижу последовательных интерфейсов…

    1. 3fc, и снова здравствуйте.
      Вечером дома буду, гляну. Сходу не вспомню.

        1. На маршрутизаторах с serial-интерфейсами использовал образа IOL, в частности L3-ADVENTERPRISEK9-M-15.4-2T.bin.

          1. Спасибо, с этим образом serial-интерфейсы появились.

    1. Алексей, день добрый!
      Очень постараюсь в ближайшее время статьи новые написать.

      1. Было бы неплохо почитать о перераспределении маршрутов между различными протоколами (EIGRP, OSPF, RIP), использовании фильтрации сетей в EIGRP с помощью prefix-list, distribute-list и route-map. На мой взгляд, материал довольно сложный, на русском толковых статей мало, если вы напишите такую — много людей вам спасибо скажет.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.